Resources

Technical Requirements

In order to take courses online at USF, you will need to meet these basic computer system requirements. Otherwise, you will not be able to access your courses through Canvas, USF's learning management system.

Please note: Canvas will run with the minimum specifications, but it is always recommended that you use the most up-to-date versions and better connections.

Screen Size
A minimum of 1024x600

Operating Systems
Windows XP SP3 and newer
Mac OSX 10.6 and newer
Linux - chromeOS
Mobile OS Native App Support
iOS 7 and newer
Android 2.3 and newer

Computer Speed and Processor
A computer less than five years old
1GB of RAM
2GHz processor

Internet Speed
Minimum of 512kbps

Screen Readers
JAWS 14 or 15 for Internet Explorer 11 & 12 and Firefox 27
Latest version of VoiceOver for Safari
There is no screen reader support for Chrome

Supported Browsers
Canvas supports the last two versions of every browser below. We highly recommend updating to the newest version. As of February 12, 2014, we support the following desktop browsers and Flash versions:

Internet Explorer 9, 10, and 11 (note: IE 9 will no longer be supported as of May 24, 2014)
Chrome 31 and 32
Safari 6 and 7
Firefox 26 and 27
Flash 10, 11, and 12 (if you want to use the audio/video recording or viewing feature or upload files)
Respondus Lockdown Browser 4.0

Certain courses may also require you to use additional technology. For example, courses that include content developed with Articulate will require you to install the latest version of Flash on your machine, and courses that use Blackboard Collaborate will require you to install the latest version of Java.